Results 1 to 3 of 3

Thread: C1 Battery load test.

  1. #1
    Junior Member
    Join Date
    Apr 2016
    Posts
    2

    C1 Battery load test.

    New Cuddeback user and new to this forum so forgive me if I have overlooked something obvious. Just went through the set up on a C1 camera I bought on E-Bay. It came in new packaging but i'm guessing is a year or more older. (The manual doesn't match the manual on Cuddeback's website) Everything works as it should except while going through the commands in the manual it has a battery level which I have and then battery load test which I don't have. Firmware version is 3.00 I believe it' the latest. This isn't a show stopper just wondering why it doesn't have it. Battery level reads full.

  2. #2
    Senior Member
    Join Date
    Feb 2012
    Location
    Oklahoma
    Posts
    109
    Congrats on the new cam! I really like mine.

    If you have version 3.0 of the firmware and if the flash has a leaf pattern embossed on it you have the newest version (extended range). There are some changes with the v.3.0 firmware that aren't represented in the online manual which is an older manual. Cuddeback hasn't updated the online manual yet. It's been long enough since I had one with the previous firmware version that I don't specifically remember the battery load test, but the new ones don't have it. Hope this helps some.
    Last edited by FredG; 04-05-2016 at 10:18 AM.

  3. #3
    Junior Member
    Join Date
    Apr 2016
    Posts
    2
    Thanks for the quick response Fred. I'm glad it's not a camera issue. I'll get her soaking in the woods for a couple of weeks and see how she does. Took some great day and night shots around the house.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •